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Accounting Exports

Important Note About LightSpeed’s Accounting Exports

It is important that you understand what LightSpeed is exporting to 
your QuickBooks accounting package. LightSpeed exports transac-
tions (Invoices, Payments, Purchases, Multi-Store Transfers, and In-
ventory Adjustments) to the General Ledger (GL) of QuickBooks as 
general journal entries.

This means that the exports debit and credit the GL accounts that 
you have linked in LightSpeed to Products/Payment Methods/Taxes/
Multi-Store appropriately as per your transactions. It does not export 
customer data or update customer accounts in these accounting 
packages, nor should you be maintaining customer accounts in these 
accounting packages. Your Accounts Receivable should be managed 
in LightSpeed.

Accounts Payable is handled in your accounting package and so 
LightSpeed exports more detailed journal entries of your purchases 
(Supplier Invoices), including your Supplier list. You will be warned of 
any errors in your export with a dialog box.

For more information, please see the Glossary of Accounting Terms at 
the end of this document. 
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Rather than exporting unique Customer Names for 
each Invoice, LightSpeed exports a single sum-
marized Journal Entry with “LightSpeed Export 
Customer” tagged as the Customer in Accounts 
Receivable. This Customer tag is a requirement 
in QuickBooks.  The default file names will again 
include the date range of the export, and an ID 
number you can save for your records for later 
referral. Exporting Invoices is how you change the 
value of your Income, Asset, and COGS accounts, 
as well as your Accounts Receivable account.
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This chapter is only for those users exporting from 
LightSpeed 2.7 or higher to QuickBooks 2009/2010 
for Mac
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Setup

Import Your GL Accounts into LightSpeed.

 1 	 Export your GL accounts from QuickBooks, at File >Export > 
Lists to IIF File, and choose Chart of Accounts when prompted. 
The settings are automatic. Click Save.

2 	 Open the GL Accounts Setup in LightSpeed in Tools >Setup 
and import the QuickBooks export file using the Import from 
QuickBooks button.  The account names, account numbers, and 
account types will be recognized automatically.

3 	 Select GL accounts for Accounts Receivable and Accounts Pay-
able in the GL Linking section.

Setup Your Tax Accounts

1 	 Open Tools > Setup > Taxes

2 	  Select a Collected GL Acct and (if applicable) a Paid GL Acct for 
the taxes you have configured. 

Setup your Payment Method Accounts

1 	 Open Tools > Setup > Payment Method 

2 	 Select a GL account for each Payment Method.

Setup your Products

1 	 Set the GL Accounts (Income, Inventory/Asset, Expense/
COGS) for each Product in the Product Window (GL Tab), or by 
batch using Set Product Info found in the Tools menu. You can 
use the Defaults tab in the GL Accounts Setup window to auto-
matically assign GL Accounts when a new Product is created. 

2 	 To ensure that the GL accounts for your Products are set cor-
rectly, run the GL reports in the Troubleshooting section of the 
Reporting window, found in the Tools menu.

GL Accounts Setup window

Product GL Accounts

The Asset and COGS accounts for non-inventoried 
Products will not be visible and cannot be assigned. 
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Setup your Locations (Multi-Store only)

1 	 Open each Supplier card that is created when you set up loca-
tions for Multi-Store Transfers.

2 	 Click the Transfers tab and select an asset/inventory GL account 
to account for your inventory while it’s in transit. This GL ac-
count should be the same for all locations.

Posting
Before Invoices, Payments, Inventory Adjustments, Transfers, or Sup-
plier Invoices (aka Purchases) can be exported, they must be posted.  
Effectively, posting means finalizing a document so that it can no lon-
ger be edited. It is important to note that Invoices and Payments are 
posted separately. Also, Transfers are posted as Supplier Invoices, but 
are handled separately when they are exported. 

There are two circumstances in which Invoices may be posted.  If you 
do not have terms with any of your Customers, and each Invoice is 
paid at the time of the transaction, you can check the Post Invoices 
When Paid option in the Company setup panel to have Invoices post 
automatically when paid.  If you do accept credit terms with your 
Customers, and you accept payments to Invoices after the transac-
tion has been completed, you can post all your Invoices, Payments, 
and Supplier Invoices over a specified date range.

To post your Invoices, Payments, Inventory Adjustments, and Sup-
plier Invoices, choose the Post By Date option of the Edit menu or 
click the Post By Date button in the Export to QuickBooks window.  
Invoices, Supplier Invoices, and Transfer Supplier Invoices that have 
been posted will appear with a green “P” beside them in the Browser; 
Payments that have been posted will appear with a green “P” beside 
them in the Payment screen of the document. Inventory Adjustments 
that have been posted will appear with a green “P” beside them in the 
Inventory Adjustments window, accessible in the Action menu of the 
Export to QuickBooks windows. 

Unposting
If you need to modify an Invoice or Payment that has already been 
posted, you can select the item and go to Edit > Unpost … whether 
it’s a Payment or an Invoice. Once you have made your change, you 
can repost the item, also under the Edit menu. If the item had origi-
nally also been exported, you can choose the Mark as Exported option 
from the Action menu of the Invoice. An option box will display al-
lowing you to choose if you want to mark the Payments or the Invoice 
(or both) as “exported”. 

You need to set the Payable Expense Account only 
for those non-inventoried Products which will be 
applied to Supplier Invoices, such as freight/ship-
ping. 

Posting by Date

You must be very careful with your unposting and 
marking as exported that you do not import data into 
your accounting software more than once. 
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Export to QuickBooks

Successful Export

Exporting To QuickBooks 
1 	 Choose the Export to QuickBooks option in the Tools menu of 

LightSpeed

2 	 Choose either a Summarized or Detailed Journal Entry export.

3 	 Click on the Setup button and enter the Sales Tax Vendor for 
each tax you have set up.  These vendors can be found in Quick-
Books, and must be entered in LightSpeed exactly as they ap-
pear on the Vendor List in QuickBooks. Click the Save button to 
save your account settings. 

4 	 Select which items you wish to export - Invoices, Payments, Pur-
chases, Transfers, Vendors, and/or Inventory Adjustments. Click 
the Back button to return to the main window.

5 	 Select the date range for your export.

6 	 Click Export. No files will be saved to your hard drive.

The result of your export will display in a green 
status box (if the export was successful) or a red 
one if it was not. 

The first time you export, or if any of your Supplier 
names have changed, select Vendors among the 
items to export, which will automatically be updated 
in QuickBooks. 

When these items are exported, the green “P” will 
become a blue “E”. 
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Pending Import

Importing To QuickBooks 	
Importing your GL Account information to QuickBooks is an auto-
matic process with LightSpeed (2.7 or higher) and QuickBooks for 
Mac (2009 or 2010 version). You must then launch QuickBooks for 
Mac to produce a window that displays the pending import. Click the 
item once to select it, and click the Import button to bring the data 
into QuickBooks. 

Confirm in each GL Account in QuickBooks that the entries were im-
ported. Remember, there won’t be any files saved to your hard drive 
that require any attention at all. 

Once your import is completed, you may return to the Export to 
QuickBooks window, click History, and check off the successfully im-

ported files, for future reference. 

Export History

In some versions of QuickBooks 2009 for Mac, you 
must turn auto-import on in the QuickBooks 2009 
Company Settings > Transaction, as that will be set 
to “off” as a default. When linking QuickBooks 2009 
for Mac with LightSpeed, you need to make sure this 
is turned on to ensure that QuickBooks is monitor-
ing. In earlier versions of QuickBooks 2009 for Mac, 
auto-import was automatic and there was no prefer-
ence to set. Please check to see if you need to set this 
preference for auto-import to function.

In QuickBooks 2010, this setting can be found at 
QuickBooks > Preferences > Transactions; make 
sure Enable AutoImport folder is checked. 

Checking History 	
The integration between LightSpeed and QuickBooks for Mac means 
that you no longer need to organize exported files, as the export/im-
port to QuickBooks does not result in any saved files. However, there 
may be times when you need to check the contents of a file in case of 
a discrepancy or if you simply want more information. 

In the Export to QuickBooks window, click History and a drawer dis-
plays all the exports that have been completed, including how many 
records were included, the date range of the export, the date the 
export was completed, and the ID number of the export. Selecting 
any of these entries will enable one or both of the buttons at the bot-
tom of the drawer, allowing you to view, in the case of Invoices or 
Purchases, a detail file of the export, or an export of the file itself, for 
all items. These files contain all the information that was exported 
the first time, and can be used to track down discrepancies between 
LightSpeed and QuickBooks. 

Clicking either button results in a file being saved to your desktop. Be 
sure not to re-import this file into QuickBooks manually. 

Manual Export	
In the case that you are emailing your exported information to your 
accountant , you can select the QuickBooks 2009 (File Export) option 
in the Export to QuickBooks window. This option saves your exports 
to your hard drive in the same way that previous versions of Light-
Speed do.  You may manually import these files into any version of 
QuickBooks using the method outlined in the Accounting Exports 
help document. 

Pending Import
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Inventoried: Products with physical inventory. 

Non-Inventoried Products: Products without physical inventory. 
Non-inventoried products tend to be services, but can also be small 
goods for which you don’t count. Although stickers have physical in-
ventory, you may not care to track it, because there are so many and 
they are very inexpensive per unit.

Income Account: The income account is used to record revenue. 
When you sell products on invoices, your income account is credited 
and it’s value increases. Both inventoried and non-inventoried prod-
ucts have income accounts.

Cost of Goods Sold (COGS): The COGS account records the value of 
goods that you have sold to customers. The value of these goods is 
recorded as the cost that you paid - not the price at which you’ve sold 
them. The COGS and Inventory/Asset Account must balance. Only in-
ventoried products have a COGS account, non-inventoried products 
do not.

Inventory/Asset Account: The Inventory/Asset account records the 
value of goods that you have received and paid for, but have not sold. 
That is, the value of goods in your inventory; items you have not yet 
sold. Inventory/Asset accounts must balance with a COGS account. 
Only inventoried products have a Inventory/Asset account, non-in-
ventoried products do not.

Balanced GL Accounts: In LightSpeed, a COGS account must be 
paired with an Inventory/Asset account. If they are not paired, that is, 
if a product has one account, but not another, they are said to be un-
balanced. Attempting to export documents that have products with 
unbalanced accounts attached to them will result in an export error.

Expense Account: This account is rarely used by LightSpeed. It re-
cords the value of pure expenses, such as shipping and handling, 
extra fees, some consumables. Products with expense accounts are 
typically non-inventoried.

Payment Accounts: These are typically bank-type accounts. They re-
cord the value of money that is taken in by LightSpeed. Some users 
will have separate accounts for each payment methods, other users 
will record all payments into one account. Other users may record 
cash and checks in one account and electronic payments in another.

Sales Tax Collected Accounts: These accounts record the value of 
sales tax that you have collected from your customers when they pur-
chases goods or services and owe to your tax vendor (government). 
Typically, you will have one account per sales tax.

Sales Tax Paid Accounts: These accounts record the value of sales 
tax that you have paid to your suppliers on goods that you have pur-
chased for resale.

Tax Vendor: Entity to which you pay sales tax. Government, board of 
revenue, etc...

Accounts Receivable (AR): Account that records the value of all 
money that you are owed. When you export invoices, AR is credited 
(increases). When you export payments, AR is debited (decreases).

Accounts Payable (AP): Account that records the value of what you 
owe all of your suppliers. Although each supplier’s account is kept in 
your accounting package, AP represents all money that you, includ-
ing other expenses entered in your accounting package.

Posted: Documents in LightSpeed that are posted are locked and 
ready to export. Only posted documents are exported; documents 
must be posted to be exported. Exported documents remain locked, 
but are marked exported instead of posted.	    

Glossary of Accounting Terms
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GL Account Type Location Notes

Accounts Receivable Accounts Receivable GL Account Setup Records the value of all money you are owed.

Accounts Payable Accounts Payable GL Account Setup Records the value of what you owe your Suppliers. 

    

Income Income Product Card or GL Account 
Setup

When you sell Products on Invoices, your income 
account is credited.

Inventory/Asset Asset “ Records the value of goods that you have received, 
but not yet sold.

Expense/COGS Cost of Goods Sold “ Records the value of goods that you have sold to 
Customers.

Payable Expense Expense / Payable “ Required only for Services entered in Supplier In-
voices, such as Shipping.

    

Each Method of Payment Bank / Holding Payment Method Setup Typically bank-type accounts that record the mon-
ey taken in.

    

Each Tax Collected or Paid Liability Tax Setup Records the value of sales tax you have collected 
from your Customers, or paid to your Suppliers.

    

Each Location (Multi-Store) Asset Supplier Card Records the value of inventory in “In Transit” status 
on Transfers Out.

Required GL Accounts

 Make sure you map GL accounts to all Products, Payment Methods, Taxes, AR and AP, and Multi-Store loca-
tions. If your export gives you errors, check your Troubleshooting reports to find missing GL accounts.

 Post before you export – Invoices, Payments, Supplier Invoices (Purchases), and Inventory Adjustments. 
Posting “finalizes” a doment or transaction. Transfers are not posted. 

 Unpost if you need to change something, then be sure to repost it and mark it exported (if necessary)

 Do not import a file into your accounting software twice.  Each export from LightSpeed has an ID number to 
identify it. 

 Exports to your accounting software are journal entries. 


