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 1   Go to Tools > Setup > Multi-Store, and enter a 3-character value 
in Store Code. This code is that code that other stores will pull 
when they add your location, and is used to identify your store 
within the multi-store setup. 

 2   Click the Add Store button at the bottom of the window to add a 
store you want to access.  

 3   Name the store you’re adding, and enter the other location’s 
external IP. You can find this number by going to the website 
www. whatismyip.com on that server. In the case that the oth-
er store have a dynamic IP, you can use a service like DynDNS to 
artifically create a static IP for that location. 

 4    Enter the User name that has been set up in the store’s data-
base for your access, and the password that has been set for 
this User. Click Save. Note: You may receive a warning that the 
record is locked; simply click OK.

	 The Supplier card for the new Store will appear. Confirm the 
information and close the window.  

In order for your copy of LightSpeed to communicate with another 
store, they must make a match on the Product being searched. There 
is an option at the bottom of the Multi-Store setup panel which will 
allow you to match solely on Product Code, or, if you have duplicate 
Product Codes, a combination of both the Product Code and the 
Family, UPC, or the Supplier Code. 

Lookups
To look up a Product in another store, click the This Store bubble that 
is revealed when the Inventory statuses are disclosed upon clicking 
the main Inventory bubble, either in the POS screen or the Preview 
Pane of the Browser. Click the location you wish to search, and the 
statuses that are displayed will be those of the other store. 

If the Product does not match with one in the location you’re search-
ing, based on what you’ve selected in the Multi-Store Setup panel, 
you will receive a dialog that says the Product could not be found in 
that location.  

Set-Up

Accessing Multi-Store Inventory Lookups in the POS

 You must have a static IP for Mutli-Store functional-
ity to work. If you have a dynamic IP, or if you’re not 
sure, please see the Networking help document on 
the documentation page of our website. 

Multi-Store Setup Detail

Accessing Multi-Store Inventory Lookups in the Browser
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Transfers

Managing your company’s multiple stores is simple with Multi-Store 
Transfers, allowing you to quickly transfer stock into and out of sepa-
rate databases, and streamlining the movement of inventory from 
one store to another.  Transfers are recorded in the inventory tab of 
Product cards once they are completed. 

You can consult the Reporting module for a list of Transfer reports 
that can be run to update you of the status of Transfers that are in-
coming, outgoing, and in transit. 

Transfers Out

To create a pending Transfer Out, choose Send Transfer Out from the 
File menu, and populate the Transfer with the Store and Product in-
formation. All Product quantities must be negative in order for the 
Products to be removed from your inventory when the Transfer is 
completed. 

1    Go to File > Send Transfer Out.  Choose the location where you 
are transferring stock. 

 2    Add Products to the Transfer as you would add Products to a Pur-
chase Order.  As you add a Product to the Transfer, notice that 
the default quantity is negative 1. If you modify the quantity, 
you must retain negative values in order to remove the Prod-
uct from your inventory and for the Transfer to work properly. 

 3    Click Save. 

 4   Click the Sending tab to confirm the quantities once you are 
physically sending them out the door.  Enter the appropriate 
quantities in the Qty Sent column. If you are sending a serialized 
Product, you must then click the Product line and add the serial 
number(s). Note: You must transfer out ALL quantities on the 
Transfer. You cannot process a partial Transfer Out. 

 5   Once you have entered the Qty Sent values for all your Products, 
click Send. The Product quantities have now been removed 
from your stock levels, and the Transfer is now “In Transit” until 
the receiving location receives the Transfer In at their location, 
at which point the status of the Transfer Out will automatically 
switch to “Sent”. 

IMPORTANT: The quantities will remain in the sending store’s 
inventory until the Transfer In is completed at the receiving 
store location. 

You can view all of your Transfers Out in the Browser by clicking the 
Transfers Out source.

Receive Transfers In button in Browser

Transfer Out

All quantities in the Qty Sent column must be 
negative.

!
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Transfers In

To update the list of your pending incoming transfers, click the Trans-
fers In icon in your Source list, and then click the Receive Transfer In 
icon at the bottom of the Browser.  Receiving the Transfer In will bring 
the stock into your available inventory. 

1    Go to File > Receive Transfer In, or click the Receive Transfer In 
button at the bottom of the Browser.  In the resulting window, 
click the pop-up menu to choose the location from where you 
are expecting a Transfer In.  (see image)

 2    Select the Transfer you wish to receive, and click the Create Trans-
fer In button. LightSpeed will create a new Transfer In which you 
can then bring into your inventory. 

 3    Click the Receiving tab. Enter the quanties of stock that you are 
receiving. If you are receiving a serialized Product, enter the se-
rial number(s) you are receiving. Click Save.  The quantities have 
now been added to your inventory, and taken out of the inven-
tory of the sending store. Once a transfer is received, its status 
will automatically reflect the change., as will the status of the 
Transfer Out from the sending store.

You can view all of your Transfers In in the Browser by clicking the 
Transfers In source.

 

Cancelling
You can cancel transfers that are in the In Transit status by changing 
the status to Cancelled. This will bring the Products back into your 
inventory. 

GL Account
In the Supplier card of the other stores, you can set a liability GL ac-
count that will be included in the export file of transfers when you 
export transactions to QuickBooks or MYOB. This GL account will be 
the same for each of your stores. For more information, see the Ac-
counting Exports help document on the documentation page of our 
website. 

Choosing Transfers In to Receive
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As a multi-user application, LightSpeed requires some minor con-
figuration of your network settings, both in OS X, and in OpenBase. 
Running LightSpeed on a central server is a simple process, but you 
should make sure that the hardware meets the system requirements 
before proceeding with your installation. 

OS X
1 	 Your server must be on a network.  Wired 100/1000 connection 

is recommended.

2 	 The server should have a static IP on the local network. Please 
contact your network administrator if you are unsure.

3 	 If server is being accessed remotely, it should have a static IP 
externally, and ports 20221-20230 should be forwarded to the 
LightSpeed server. (see below)

OpenBase
1 	 Launch the OpenBase System Preference panel.

2 	 Select the Start OpenBase Processes at Computer Startup check-
box (if unchecked).

276	 OS X

276	 OpenBase

277	 LightSpeed

277	 Remote Log-In
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3 	 Select the Enable Network Access checkbox. The host name and 
internal IP should auto-populate in the appropriate fields.

4 	 It is not recommended that Automatic IP Address be selected. 
Contact Xsilva if you have questions regarding this setting.

LightSpeed
1 	 Click the Servers button upon log-in. 

2 	 Enter either the local static IP of the server, or its local host 
name. 

3 	 Log in as you would normally. 

Remote Log-In
1 	 Secure an external static IP for your server. If your IP is dynamic, 

use a dynamic DNS service to create a host name that can be 
used for remote log-in. An example of a dynamic DNS service is 
www.dyndns.com. 

2 	 Make sure ports 20221-20230 are forwarded to your Light-
Speed server. 

3 	 Click the Servers button on the computer logging in remotely.

4 	 Enter the static IP or host name and log in as you would nor-
mally. 

If you are using a software firewall, it must allow 
access to ports 20221-20230. If you have questions, 
see your local network administrator.
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POS Hardware
LightSpeed is able to communicate with a wide range of the POS 
hardware you require in your operation, including label printers, cash 
drawers, and barcode scanners.  Configuration of these devices is 
generally very simple, and can be completed quickly following a few 
basic steps.  

Barcode Scanner
The most elemental of input devices, barcode scanners have only 
one function – to read a visual code required to identify an object 
or piece of information, and input that information into the system.  
They can be purchased with or without a trigger, but nearly all USB 
barcode scanners are compatible with LightSpeed and will comply 
with the software’s requirements for data entry.  The one necessary 
attribute is for the scanner to send a return command after the data 
is scanned, as if the Return key had been pressed.  However, the vast 
majority of USB barcode scanners have this ability. Barcode scanners 
do not require Mac drivers. 

278	 POS Hardware

278	 Barcode Scanner

279	 Receipt Printer

279	 Cash Drawer

280	 Pole Display

280	 Label Printer

281	 Card SwiperCo
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Receipt Printer
LightSpeed gives you the option to print Invoices on either 8.5” x 11” 
or receipt format.  Star Micronics is the only receipt printer manufac-
turer that ships their printers with drivers for Mac OS X, available in 
the TSP-100 and the TSP-600 series. 

Configuration for the Star Micronics printers happens in the Station 
Setup panel, found under the File menu.  Choose the Receipt option 
in the Printing section of the Station setup panel.  Click Save at the 
bottom of the window.  Then, choose the Page Setup option from the 
File menu.

Choose your TSP printer in the “Format For” pop-up menu, and 
choose 72mm x 2000mm as the Paper Size.  Click OK, and a dialog box 
will appear asking if you want to save this Page Setup for future print 
jobs.  Choose Save for Receipt Printing, and click Yes.  

Cash Drawer
In terms of compatibility, almost any cash drawer with an RJ-45 or se-
rial connection will work with LightSpeed.  There are three options for 
connecting a cash drawer to your computer – either directly via USB, 
using a USB-serial adapter, or by connecting it first to a receipt printer 
via an RJ-45 to RJ-11 cable.  

USB

The APG Vasario USB cash drawers connect directly to your Mac’s USB 
port. Choose USB Drawer in the Station Setup panel. 

Via a Receipt Printer

Connect the cash drawer to the receipt printer with an RJ-45 to RJ-11 
cable.  To configure the cash drawer to open when the receipt printer 
is activated, go to the Print Dialog by clicking the Print button in any 
existing Invoice.  

Choose your TSP printer in the first pop-up menu.  Choose Printer 
Features in the third menu.  A fourth menu will appear; choose Cash 
Drawer Control.  A further set of two menus will appear; in the first, 
choose Open Drawers 1 and 2, and leave the last menu set to 200 mil-
liseconds.  When you click the Print button, the printer should be acti-
vated and kick the cash drawer open. 

Setting up Receipt Printer

Setting the Cash Drawer in OS X Print Dialog

Setting Cash Drawer in Station Setup



 

280
Chapter 07 Setup and Administration POS Hardware

Label Printer

Dymo LabelWriter

To access the Dymo LabelWriter, choose the Dymo LabelWriter tab in 
the Print Customer Labels or Print Customer Labels window, and select 
the label size you’re printing to with the pop-up menu.  Installing the 
Dymo LabelWriter requires you to connect the printer only when 
prompted to do so after installing the drivers. (see Printing Labels 
chapter for more info)

Via USB to Serial Adapter

First, you must install the adapter and its drivers, and connect the 
cash drawer’s serial cable to the adapter. You may need to unscrew 
an access panel to connect the power supply to the drawer - refer 
to the drawer’s documentation.   In File >Station Setup, select Serial 
Drawer Connected via USB Adapter, choose a port (likely 0 or 1), and 
click Save.  You can test it by clicking Apple-/.  

Pole Display
The Logic Controls TD3000 USB pole display can be connected di-
rectly to your Mac’s USB port. Choose USB Pole Display in your Station 
Setup panel. 

To set up your serial pole display via USB adapter, you must first in-
stall your Keyspan Serial to USB adapter, and plug your pole display’s 
serial cable into the serial port on the adapter. Once both the serial 
and power cables are connected, you are ready to configure Light-
Speed for use with the pole display. In File  >Station Setup, click on 
the Pole Display pop-up menu and choose ‘Serial Pole Display via USB 
Adapter’. Select a port (likely 1 or 2).  Click Save. 

Unfortunately, due to the limitations of serial technology, there is no 
way for LightSpeed to tell which port is correct, so you will have to 
try adding a Product to an Invoice or the POS screen to see if it works.

  If you are alternating between a receipt printer, 
a label printer, and/or a laser printer from the 
same station, choose Last Printer Used in the 
Selected Printer in Print Dialog pop-up menu in 
the Print & Fax panel of your computer’s System 
Preferences. If you need to change printers, do so 
in the Print Dialog box when you’re ready to print 
the document, whether it’s a Quote, labels, or an 
Invoice.  
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Card Swiper
Like barcode scanners, USB card swipers are simply reading devices 
and are universally compatible.  They are available as stand-alone 
units, or as part of a USB keyboard.  In LightSpeed, card swipers are 
used to read credit cards for internal processing, or for reading the se-
rial numbers of gift cards.  When plugging in card swipers for the first 
time, it is important you do NOT “tell” your Mac that it is a keyboard.
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Printing
Whether it’s Product labels, sales documents, or packing slips, there 
are times when you need to commit something to paper. Here is a 
quick guide to LightSpeed’s printing capabilities.

Full Page vs. Receipt Layout
All sales documents - Quotes, Invoices, Orders, and SROs – can be 
printed in full-page (8.5x11 or A4) format, and can: 

	  Include Product images, Printed Notes, and Discount Margins

	  Include Custom Fields for documents, Customers, or Products

	  Include Fine Print to outline your company’s policies and 
procedures

	  Include a Document Barcode for document scanning 

	  Be printed in one of three default languages - English, 
French, or Spanish

	  Be configured to be printed in any OSX-friendly language (us-
ing Field Translations)

Invoices can also be printed on Receipt layout, and include all data 
listed above with the exception of Product images. 

Co
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 Only Invoices can be printed on receipt 
layout

 Setting up a receipt printer requires a Page 
Setup the first time

 Documents, reports, and AR statements can 
be printed in Full-Page layout

 Labels can be printed for Products or Cus-
tomers, and can be customized

 Action menus offer printing options for 
documents, profiles, and labels

 Station Setup allows you to indicate full-
page or receipt layout for Invoices

 Printer Setup allows you to specify printer 
models for Full-Page, Label, and Receipt 
printers

282	 Printing

282	 Full Page vs. Receipt Layout

283	 PDF Print Backgrounds   
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284	 Reports

284	 User Reports

284	 Batch Printing

284	 Action Menu

285	 Choosing Printers
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PDF Print Backgrounds   
Branding customization of full-page printed documents can be done using 
PDF Print Backgrounds. This allows you to customize an 8.5x11” PDF that 
includes your customized header and footer section, as well as watermarking 
you’d like to add to the body of the document. 

To add your customer 8.5x11” PDF Background, go to Tools > Setup > PDF 
Backgrounds, and choose Quote, SRO, SRO Claim, Order, Invoice, PO, or State-
ment.  Then, drag your PDF and drop it into the space indicated.  Choose Print 
Blank PDF if you want a blank PDF added to any specific document. 

PDF Print Background
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Labels
Product labels or Customer labels can be printed from either the 
Product or Customer card itself, or under the Tools menu. Labels can 
be printed spool-style, or on label sheets. Barcodes are normally 
produced by the Product’s UPC code, but in the absence of a UPC, 
you can use the Product ID as a barcode. Product labels can include 
tax-inclusive selling prices, or Pricing Level prices. The Label De-
signer will allow you to create custom labels and print them on any 
CUPS-compatible printer. (For more on printing labels, see the Label-
ing document found on the PDF Documents section of our Training 
page at www.xsilva.com)

Reports
Each report can be produced in PDF format, and printed in full-page 
format. (For more info, see the Reporting document from the Training 
page at www.xsilva.com)

User Reports
User Reports can be accessed at File >Print User Reports, and can 
produce:

1 	 Payments - Shows a breakdown of each Payment Method, the 
User, number of transactions, and total

2 	 Timesheet - Shows start/stop times, hours worked, and Jobs/
Tasks performed, by User, over a date range

3 	 End of Day - Shows a breakdown of sales, payments, returns, 
and beginning/ending tills for a specific day

Batch Printing
Batch Printing (File >Print Batch…) allows you to print batch In-
voices and statements for Customers with outstanding balances over 
a date range, and can be filtered to view Credits, Paid, and Invoices 
Owing 1-30 days, 30-60 days, etc.

Action Menu
From the Action Menu of profiles, documents, and labels, accessed 
by the “gear” icon at the bottom of the relevant window, you have 
several options regarding printing:
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	  Quotes and Orders – Packing Slips

	  Invoices – Receipt, Full Page, Packing Slips, Box Labels, Gift       
Receipts

	  Purchase Orders – Product Labels

	  Products and Customers – Labels

	  Product Labels – Auto-populated prices and quantities

Choosing Printers
LightSpeed allows you to specify various printers and formats for the 
range of printing requirements in LightSpeed, including Invoices, la-
bels, and receipts. 

 1 	 Station Setup

	 If you wish to bypass the OS X print dialog box, enter the num-
ber of copies you’d like printed when you print an Invoice, and 
choose Without Dialog Box from the pop-up menu. However, if 
you are using your receipt printer to kick open your cash draw-
er, you must not bypass the OS X print dialog box. 

	 To specify which format to print your invoices to, go to File 
>Station Setup, and click “Full Page” or “Receipt” next to Print-
ing. To indicate which particular printer model that you are 
printing to, see the section below on Printer Setup. 

	 To set up a receipt printer for the first time, you must perform a 
page setup. Go to File >Page Setup, and choose to format for 
the Star Micronics printer. Choose the 72mmx2000mm paper 
size, and from the Settings pop-up menu, choose Save as De-
fault. Click OK. You will see another dialog appear – choose Save 
for Receipt Printing, and click OK. 

 2 	 Printer Setup

	 To set the destination printer for various printer workflows in 
LightSpeed, click the Printer Setup button at the bottom of the 
Staton Setup panel. In the resulting window, you will be able to 
choose the printer models you wish to perform the following 
functions: Full Page printing (sales documents and reports); 
Label printing (Products and Customers); and Receipt printing 
(Invoices only). For each function, you can choose the system 
default (defined the the Print and Fix System Preference), or the 
exact model of the printers you have installed. 
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Trackers
The Trackers feature of LightSpeed is a way for you to customize a 
set of notifications that are relevant to you. From a list of close to 100 
headings ranging from telephone calls you need to follow up on and 
Orders you need to invoice to Web Orders ready to process, each User 
in LightSpeed can configure their Trackers to list only those catego-
ries that concern them. For example, a service technician might con-
figure his Trackers to include the various stages of SROs to which his 
name is attached, whereas the service manager might want to track 
all open SROs for all technicians. When a User is logged in, their Track-
ers will be displayed in the Browser. 

Installed Trackers can be displayed all at once, or individually, and 
are accessed in the left section of the Browser. Clicking any Tracker 
will result in the pertinent documents displayed as a list in the main 
section of the Browser. To see them all at once, click All Trackers. Be-
side each Tracker, the number of relevant documents will appear in 
a circle.

To configure your Trackers, click the Setup button at the bottom of 
the Browser for access to the Tracker Setup window. In the first col-
umn all available Trackers will be listed, and can be sorted alphabeti-
cally by clicking the header, or reverse alphabetically by clicking it a 
second time. 

To install a Tracker, simply drag it from the first column to the sec-
ond; multiple Trackers can be installed using the Command (Apple) 
key. A Tracker can be highlighted in red in the Browser by clicking the 
Alerted checkbox. 

You may also filter the results of any Tracker, according to the time the 
document was or was not created or modified, as well as a list of fields 
which will limit your Tracker to a particular class, code, description, 
family, or supplier. Once you have settled on the list of Trackers you 
wish to install, click Save. To see the changes to your Trackers, click the 
spinning arrow Refresh icon in the Browser. 

Trackers for Quote or SRO statuses will be added to 
your available Trackers as you create or edit statuses 
in the setup panels of the Tools menu. 

Trackers in the Browser

Tracker Setup

Tracker Filter


